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System requirements 

The following table lists the minimum system requirements to install and use Editor OPM Vers. v.1.72c. 

 

Hardware/Software Required 

Processor Pentium 

RAM 32 MB 

Free disk space 16MB 

CD-ROM drive Any speed 

Operating system 
Windows 95, Windows 98, Windows Me, Windows NT, 

Windows 2000, Windows XP (Windows Vista) 

Monitor SVGA (800x600) 

Peripherals Keyboard and mouse 

 

In case the user wants to print messages and settings a printer connected to the PC is needed. 

Materials supplied 

Materials supplied consist of: 

 CD-ROM containing the software installation program. 

 Software user manual. 

Installation setup 

Editor OPM can be executed on Windows 95, Windows 98, Windows Me, Windows NT, Windows 2000, Windows XP 

(and Windows Vista). 

1. Insert Editor OPM CD-ROM in the CD reader. 

 When installing the software on Windows 95/98, install also: 

\Support\WMI\Italiano wmicore.exe (on an italian operating system) 

\Support\WMI\English wmicore.exe (on an english operating system) 

\Support\DCOM\Windows 95\dcom95.exe (on Windows 95) 

\Support\DCOM\Windows 98\dcom98.exe (on Windows 98) 

Restart the system. 

2. Launch  Editor OPM01 v. 1.72c full setup.exe located on the setup CD. 

3. Follow the instructions to install Editor OPM. 
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Program startup 

Start the program from Start or Start\Programs\Editor OPM v. 1.72c. 

At the first program start the user has to communicate to Logomat s.r.l. the "authorization key" to obtain the program 

activation code. 

The request can be made by phone (english speaking staff will answer), fax or E-mail. 

The authorization code is made up of 12 digits/letters. If the program is closed before entering the activation code a 

new authorization code will be created on the next program start. 

The program activation code, provided by Logomat S.r.l., allows the software to run only on the PC for which the 

code was requested. 

 

 

The program startup window looks like a grey window where the only active button is "File". 
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1. Introduction 

The present chapter provides some introductive information about the OPM01 display programming software, giving 

also an overview on the software main function. 

1.1. Preliminary information 

The OPM01 management software is an application developed by Logomat to provide the operator a valid support 

to create and manage any machine alarm that can be displayed. 

The software allows the user to: 

 Create a new list of the messages displayed. 

 Create a messages list basing on an already existing one. 

 Set selectors. 

 Create and manage counters. 

1.2. Messages 

The messages shown on the display can be of 3 different types: 

 

 Alarm messages. 

 System messages. 

 Help messages. 

 

Alarm messages can be set by any user. During the programming these messages are shown on the display 

depending on the input signals (see the display user manual). A message can have one or more corresponding 

messages in other languages up to a maximum of 8 languages. 

There are 128 alarm messages available. 

 

System messages are automatically shown on the display when certain conditions occur. These messages can be set 

only by an authorized user, as their management is protected with a key code. Each message can have one or 

more corresponding messages in other languages up to a maximum of 8 languages chosen among the ones 

available for the alarm messages. 

There are 128 system messages available. 

 

Help messages are used by the operator to get information about the alarm or system message displayed. These 

messages are displayed only if requested by the operator (using the HELP button). Each message can have one or 

more corresponding messages in other languages up to a maximum of 8 languages. 

There are 128 help messages available. 
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1.3. Selectors 

Besides displaying messages, OPM01 can manage buttons, 2-3-4 positions selectors, and up to 8 2-positions 

selectors/buttons. 

1.4. Counters 

OPM01 can manage several counting signals up to a maximum of 8 counters. The value of the counters can be 

shown into the messages. 

1.5. Menu 

OPM01 has menu items to allow displaying its status or setting production parameters. 

There are two types of menus: 

 Standard menu. 

 Customized menu. 

Standard menus are always present and allow displaying languages, selectors and counters. Information provided 

can be changed basing on the user’s needs or simply consulted. 

Customized menus are set basing on the customer’s needs. 
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2. Creating and modifying display messages 

This chapter explains how to insert, modify and manage the messages displayed on the OPM01. 

Messages are divided into: 

 Alarm messages. 

 System messages. 

 Help messages. 

2.1. Alarm messages 

Alarm messages are text messages displayed on the OPM01 basing on the external signals received (see OPM01 user 

manual). 

2.1.1 Creating alarm messages 

Choose File>New to create new messages. 

The window "Choose a language" will be displayed (Fig. 2) 

 

Choose the languages for the display messages among the available ones. 
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Note: the number of languages that can be chosen is less or equal to 8  

 

Languages to be included can be selected by clicking twice on their name. It is also possible to select a single 

language and then include it by clicking the button. 

In case an unwanted language is inserted, exclude it by double-clicking its name in the list "Selected languages" or 

select it and then click the button . 

After selecting all the desired languages, clicking the button brings back to the window “Editor OPM" (Fig. 

3), in which new tools to display and manage messages are available. 

 

 

Clicking the button in Fig. 2 brings back to the window "Editor OPM" seen in Fig. 1.  

Clicking the button in Fig. 3 allows opening a previously saved file from which existing messages can 

be copied. 



SOFTWARE MANUAL EDITOR OPM V. 1.72C 

 11 

 Rev. 2.00 

This document is a property of LOGOMAT s.r.l.  

No part of this document may be reproduced without the prior explicit permission of LOGOMAT s.r.l. 

 

2.1.2 Modifying alarm messages 

Alarm messages can be modified by directly typing into the window "Message" (Fig. 4). 

 

 

 

 

Enter the text in correspondence of the cursor position. The text can be centered by double-clicking into the 

window. 

Text can be deleted in several ways: 

 Using the "Backspace" button, which deletes the text typed at the left of the insertion cursor 

 Using the button "Del" key which, in the same way as Backspace, deletes the text one char at a time 

rightwards starting from the insertion cursor. 

It is also possible to delete text blocks after selecting them using the cursor, by clicking with the mouse on the text 

start point and dragging the cursor to the end of the selection or by clicking and, while pressing the "Shift" button, 

clicking again at the end point of the selection. Then press the "Del" button to delete the selected text... 

 

The whole text can be selected through the menu item Modify>Select all. 

 

Text can be copied into the "Clipboard". The clipboard is a Windows standard feature and is a system memory area 

which temporarily stores data (see Windows documentation for more details about Clipboard). 

To copy a text into the Clipboard select it and then choose the menu item Modify>Copy (or the keys Ctrl + C), then 

move the cursor in the position in the document where to copy the Clipboard content and choose Modify>Paste (or 

keys Ctrl + V). To move a text just use the menu item Modify>Cut instead of Modify>Copy. Move the cursor in the 

proper position and select Modify>Paste. 

Use the arrow keys and the navigation keys (“Home” and “End”) to move into the text. 

 

The message cannot be longer than 4 lines with a maximum of 20 characters per line. 

If more than 4 lines are inserted the text background becomes red and moving to another message is not allowed 

until the problem is solved. 

Fig. 4 
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2.1.3  Scrolling alarm messages 

Scroll through the 128 alarm messages available using the scroll bar (Fig. 5) located under the messages window. 

 

Another way to scroll the messages is using the keys "Page up" and "Page down", which will scroll the messages one 

by one. 

The number of the message currently displayed in the display box is always indicated besides the "Message" 

indication (Fig. 6): 

 

 

Fig. 5 

Fig. 6 
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2.2. System messages 

System messages are shown on the display when certain particular conditions occur (see OPM01 user manual). 

The configuration of these messages requires entering an access key, using the menu item Display>Complete Menu. 

Only Logomat S.r.l. is authorized to use this functionality. 

 

IMPORTANT! 

The first system message (Message 129), which can be normally displayed and modified even in the incomplete 

menu, is the presentation message i.e. the message shown for 2 seconds when the display is powered on.  

It usually indicates the name of the factory where the machine was produced. 

System messages numbers go from n.129 to n. 256. 

2.2.1 Creating system messages 

When creating alarm messages, system messages in the selected languages are automatically loaded (see 

"Creating alarm messages"). 

2.2.2 Modifying system messages 

System messages can be modified by typing directly into the "Message" window (Fig. 4). 

Fig. 7 
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All the explanations about managing the text in the section "Modifying alarms messages" are valid for system 

messages too. 

2.2.3 Scrolling system messages 

Scroll through the 256 alarm and system messages available using the scroll bar (Fig. 5) located under the messages 

window (Fig.5). 

All the explanations about scrolling the messages in the section "Scrolling alarms messages" are valid for system 

messages too. 

2.2.4 Alarm or system message blinking 

System or alarm messages can be set to be blinking when they are shown on the display. 

Select the alarm or system message to be set as blinking. In the "Properties" box (Fig. 8) check the check-box "Blink". 

 

Fig. 8 
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2.3. Help messages 

Help messages are text messages that the operator recalls using the "Help" button to get explanations about the 

system or alarm message displayed. 

2.3.1 Creating help messages 

When creating alarm messages, help messages in the selected languages are automatically loaded too (see 

"Creating alarm messages"). 

2.3.2 Modifying help messages 

Modify help messages by typing directly into the "Help" window (Fig. 9). 

 

All the explanations about managing the text in the section "Modifying alarm messages" are valid for help messages 

too. 

2.3.3 Scrolling help messages 

Scroll the 128 help messages using the scroll bar (Fig. 10) located under the help messages window. 

 

All the explanations about scrolling the messages in the section "Scrolling alarm messages" are valid for help 

messages too. If the complete menu is enabled, the number of help messages available is 256. 

 

Fig. 10 

Fig. 9 
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2.3.4 Associating a help message 

A help message can be associated to an alarm or system message. Select the alarm or system message to which 

the help message has to be associated. In the "Properties" tab (Fig. 11) digit into the "Linked help” box the 

corresponding number of the help message to associate. 

 

Select the associated help message to see from the list “Linked messages" (Fig. 12) the list of the system or alarm 

messages to which the help message is associated. 

 

Use the vertical scroll bar to scroll the alarms list. 

 

Fig. 11 

Fig. 12 
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2.4. Messages language 

Change the messages language in order to see or modify them in the various languages by selecting the respective 

language tab in the "Languages" section (Fig. 13). 

In the example shown in Fig. 13 the only languages are Italian and English. 

The alarm, system and help messages will be shown in the selected language. 

2.4.1 Adding a language 

To add a language, select the menu item Language>New language. The window "Choose language" (Fig. 14) allows 

selecting one or more languages among the listed ones, as previously explained in the section "Creating alarm 

messages". 

 

Fig. 13 
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Remember to update the menu Counters and Selectors, as the settings for the new languages will be 

copied basing on the first language inserted. 

 

2.4.2 Deleting a language 

To delete a language select the menu item Language>Cancel language. The window "Cancel language" (Fig. 15) 

allows deleting one or more language among the listed ones. 

 

A language can also be deleted by double-clicking its name; this operation will delete the language from the list 

shown. Pressing the button will remove definitely the languages no more present in the list. 

Pressing the button in the Fig. 2 brings back to the "Editor OPM" window in Fig. 1 without deleting any 

language. 

 

Fig. 15 
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3. Selectors – counters - menu 

This chapter explains how to set and use the following tools: 

 Selectors 

 Counters 

 Menu 

3.1. Selectors 

Besides working as a display, OPM01 has function keys (see OPM01 user manual) to create buttons or selectors with 

two, three or four positions. 

OPM01 can have a maximum of 8 2-positions selectors or buttons. 

 

3.1.1 Setting selectors 

Access the selectors list through the menu item View>Selectors. The "Selectors" window (Fig. 16) allows setting the 

selectors. 

The following parameters can be set: selector description, positions number, key input, output address and selector 

type. 

3.1.2 Selector description 

Type the selector description in the column "Selector description". 

The selector description is also shown in the selectors list (see section "Lists"). 
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3.1.3 Positions No. 

The positions number of a selector goes from a minimum of 2 to a maximum of 4. 

To define the positions number of a selector type the text directly into the columns "Pos. 1", "Pos. 2", Pos. 3" and "Pos. 

4" which indicates the current selector. To create a 2-positions selector or a button, just fill the columns "Pos. 1" and 

"Pos. 2" in the line corresponding to the selector. To create a 3-positions selector instead, fill the columns “Pos. 1" "Pos. 

2" and "Pos. 3" in the line corresponding to the selector. Follow the same logic for a 4-positions selector. 

The total text length resulting from the combination of "Selector description” plus "Positions number" cannot 

be greater than 18 characters. Spaces are automatically added to align to right the selectors positions 

values. 

3.1.4 Key input 

The key input is the hardware input (see OPM01 user manual) to which a signal disabling the selector status change is 

sent. 

The selector has no limitations in case this key is not present. 

Accepted values are: 

 Inputs from 2.0 to 2.7 

 Input 3.7 

3.1.5 Output address 

The output address is the hardware output (see OPM01 user manual) to which the selector status signal is sent. The 

low address will be indicated for 3 or 4 positions selectors. The high address is the next one, and cannot be used by 

any other selector. 

Accepted values are: 

 Outputs from 1.0 to 1.7 

3.1.6 Selector type 

There are 2 types of functions: selector and button. 

A selector keeps the value it is set to. Its status can only be changed by selecting it on the OPM01 and pressing Enter. 

A button keeps its status only while the Enter button is pressed. Unlike a selector, a button can only have 2 positions. 

The selector type can have the following values: 

 1 for button mode 

 2 for 2-positions selectors 

 3 for 3-positions selectors 

 4 for 4-positions selectors 
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3.1.7 Selectors language 

Change the selector language to display or modify them in the different languages by selecting the tab with the 

language desired from the window "Selectors" (Fig. 16) 
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3.2. Counters 

Some input signals on the OPM01 carry data about events occurring repeatedly, such as consecutive errors, times 

and all the events that can be counted (see the display user manual). These events can be monitored using the 

OPM01 counters. 

Counters can be displayed into the messages text by double-clicking the counter description into the windows in the 

"Languages" tab. This operation will make the text [C0X] to be displayed in the insertion position defined by the cursor 

position in the text. X indicates the number of the counter. For example, [C01] corresponds to the numeric value 

stored in the first counter. OPM01 substitutes this text with the numeric value of the counter it refers to. The text 

entered occupies the number of characters specified in the field "Digits No." of the window "Counters", for example: 

[C01 _ _ _] for a 3 digits counter. 

OPM01 can have up to 8 counters. If a counter is deleted all the texts will have to be modified manually. 

 

3.2.1 Setting counters 

Access the counters list through the menu item Display>Counters. The window "Counters" (Fig. 18) allows configuring 

the counters. 

The parameters that can be set are: counters description, digits number, resettable, key input, input address and 

counter type. 

 

 

Fig. 17 

Fig. 18 
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3.2.2 Counters description 

An alphanumeric description can be assigned to the counters. 

Type the text directly into the column "Counters description" in the line corresponding to the desired counter. 

The total length of the text cannot exceed 18 characters. 

3.2.3 Digits No. 

The number of digits indicates the maximum number of digits that can be shown on the display. For example, if the 

maximum number to be displayed is "99999" the number of digits to choose is 5. 

The digits number for the counters goes from a minimum of 5 to a maximum of 10 digits, which means a maximum 

reachable value of 4.294.967.296. 

3.2.4 Resettable 

The value Resettable of a counter has to be set to “1” for the operator to be able to reset the counter value. 

This operation will add the counter to the menu "Counters Reset". 

In case this value is not set the counter cannot be reset. 

Accepted values are: 

 0 Not resettable 

 1 Resettable 

3.2.5 Key input 

The key input allows disabling or enabling the reset of a resettable counter using an external signal, usually 

generated from a key selector. 

The counter will have no limitations in case this key is not set. 

Accepted values are: 

 Inputs from 2.0 to 2.7 

 Input 3.7 

3.2.6 Input address 

The input address is the hardware input (see OPM01 user manual) on which the counting signal is received. 

Accepted values are: 

 Inputs from 2.0 to 2.7 

 Input 3.7 (only for speed counter and hour counter) 

3.2.7 Counter type 

A counter can be a production counter, a speed counter or an hour-counter. 
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A normal counter allows counting pulses, coming from the inputs previously described, whose logical values don’t 

change at an excessive speed (see OPM01 user manual). 

A speed counter converts a series of input pulses into a numeric value indicating the machine speed basing on the 

ratio used to obtain the pulses. 

An hour counter records the presence of an input signal and converts it in time values. 

The counter type can have the following values: 

 15 for speed counters with an input ratio of 15 teeth 

 30 for speed counters with an input ratio of 30 teeth 

 60 for speed counters with an input ratio of 60 teeth 

 H for hour-counters 

 C for production counters 

3.2.8 Counters language 

The counters language can be changed by selecting the tab with the name of the preferred language in the 

window “Counters" (Fig. 18). 

3.3. Menu 

Menus consist of a list of information or macros to execute machine functions that can be displayed through OPM01. 

There are 2 types of menu: 

 Standard menu 

 Customized menu 

Standard menus are always present and allow displaying languages, selectors and counters. Data available can be 

modified or just consulted. 

Customized menus are configured by the Customer basing on his needs. 

3.3.1 Setting menus 

Access to the menus list through Display>Menu in the window "Menu" (Fig. 19) where menus can be configured. 

The following menus are shown: 

 Menu n° 1 Selectors 

 Menu n° 2 Menu 

 Menu n° 3 Counters 

 Menu n° 4 Counters Reset 

 Menu n° 5 Languages 

 Menu n° 6 (internal) 

 Menu n° 7 (internal) 

 Menu n° 8 (internal) 

 Menu n° 9 (internal) 
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The parameters that can be set are: list flag, key input and menu items descriptions. 

Selecting menu 1 (Selectors), 3 (Counters), 4 (Counters reset), 7 or 8 will show the following message: 

"Reserved menu. Accessible only by enabling the complete menu". 

3.3.2 List flags 

The list flags in the base version cannot be changed, as their management is reserved to a user having special 

permissions. 

3.3.3 Key input 

The key input is the hardware input (see OPM01 user manual) to which a signal is sent that disables using the menu 

item. 

Accepted values are: 

 Inputs from 2.0 to 2.7 

 Input 3.7 

Fig. 19 
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3.3.4 Menu items description 

Menu items can be modified for each language used. 

Type the text directly into the column indicating the language and in the line corresponding to the desired item. 

The total length of the text cannot exceed 18 characters. 
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4. Data transmission 

Editor OPM can communicate with OPM01 through a serial communication. The communication can be managed 

through the window "Communication with OPM01" (Fig.20), which can be accessed through File>Data 

Transmission>OPM01 <==>PC, depending whether the data transfer is from OPM01 to PC or vice versa. 

 

 

4.1. File selection 

The button allows selecting the file to send to the display. 

 

4.2. Serial communication setting 

To enable transmission/receipt on the OPM01, enter the OPM01 menu and select the item "Data transmission". 

Once the item is selected, OPM01 starts to transmit on the serial port a data sequence necessary to be 

acknowledged by the PC it is connected to. 

Using the button, the program detects the serial port of the PC being used to receive the data. 

Fig. 20 
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Once data are received and the serial port connected to OPM01 is identified, a check signal is sent to OPM01 to 

stop it sending its identification data. 

Use the button  only if the number of the PC serial port connected to OPM01 is unknown; if the number of 

the port is known use the button. After “detecting” or “setting” the serial port number, the program 

detects the type of EEPROM (FLASH model) installed on the OPM01, the firmware and the transmission software 

versions installed on the OPM01. If available, pressing the button shows the firmware version release date. 

Pressing the button       sets the serial port using the data defined in the boxes "Set serial port", i.e.: 

 Serial port 

 Transmission speed 

If no answer is received from the display there may be a connection problem or a data misalignment between PC 

and OPM01. 

Pressing the button presumes that the OPM01 is connected to the right serial port and is in "Data 

transfer" mode. If not, a procedure starts to “realign” the transmission between PC and OPM01; this procedure is 

executed every time there is a transmission error during a reading or a programming session. 

In order to re-synchronize the display up to 255 synchronization characters (which is the maximum length of a data 

block that can be transmitted to OPM01) are sent. As bytes are sent every tenth of second it takes a maximum of 

25,5 seconds to complete the realignment procedure. 

If the communication is not re-established after these operations there may be a hardware problem. Check the 

connections and that OPM01 is in "Data transfer" mode. 

Remember to set the communication speed at 9600 bps. 

4.3. Programming and reading 

After setting the communication it will be possible to read from and write to the Flash Eprom. Reading data does not 

change the EPROM content, while writing erases the EPROM content. 

4.3.1 EEPROM reading 

Press the button (Read FLASH) to read the display EPROM content. These data are sent to the program to 

modify the messages and are recorded in a file. 

The button (Read FLASH) is enabled only after detecting an OPM01 connected to the system. 

If during the reading there are transmission errors the program will try to restore the connection by sending proper 

control and realignment codes. 

When the reading is complete the software remains waiting for another read or write. 

4.3.2 EEPROM writing 

Press the button (Program FLASH) to: 
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 Erase EEprom in 10 seconds 

 Send 64 bytes block to program the Eprom 

The scroll bar indicates the programmation advancement. 

If during the writing there are transmission errors the program will try to restore the connection by sending proper 

control and realignment codes. 

When the writing is complete the software remains waiting for another read or write. 

4.4. Erase list 

The button deletes the content of the messages display box. 

4.5. Back to Editor OPM 

The button brings back to Editor OPM01. 

4.6. General information 

The upper right section of the window "OPM01 Communication" (Fig. 21) shows into three separate fields the Eprom 

FLASH model, the software version and the software programming date. 

 

Fig. 21 
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5. Customer data 

The window "Customer data" (Fig. 22) allows viewing and modifying data regarding: 

 Customer 

 File name 

 Machine name 

 Last update date 

 Matriculation number 

 Version 

 

 

 

 

 

 

 

 

 

 

 

6. Sending updates to the customer 

Copy into a floppy disk the following files: 

 *.BIN (renamed "DISOPM.BIN") 

 WCOM1.EXE 

 WCOM2.EXE 

 CLEAR.BIN 

 C0LOADF2.BIN 

The last 4 files are located in the directory "PROGROPM". 

The customer will have to perform the following operations: 

1. Connect the OPM01 to the PC serial port 

2. Set the OPM01 in data transfer mode 

3. Execute the program WCOM1.EXE if the display is connected to serial port COM1 or WCOM2.EXE if it is 

connected to serial port COM2. 


